• 0 Vote(s) - 0 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Need date captured for a variable to apply time zone
#1
Hi,

For a notification from an Action, that we are generating in a Related Process used by a Business Rule, we are using an 'Internal Update Step' to populate a variable that captures the creation_date_ut of a different Action associated with the same ticket (REQUEST_ID).  The problem we have is that the date captured and stored in the variable does not apply the time zone like a date field directly from the Action that the notification is generated from, it instead displays in UTC, which for me in EDT is 4 hours off.

Has anyone else had this same issue and perhaps has a solution or workaround?  I don't want to re-invent the wheel if someone else has already found a way to do this.  I can't just subtract 4 hours, since our user community works out of a number of different time zones.  Any suggestions would be appreciated. 

Thanks,
Audrey

#2
(06-21-2018, 12:03 PM)audreyh Wrote: Hi,

For a notification from an Action, that we are generating in a Related Process used by a Business Rule, we are using an 'Internal Update Step' to populate a variable that captures the creation_date_ut of a different Action associated with the same ticket (REQUEST_ID).  The problem we have is that the date captured and stored in the variable does not apply the time zone like a date field directly from the Action that the notification is generated from, it instead displays in UTC, which for me in EDT is 4 hours off.

Has anyone else had this same issue and perhaps has a solution or workaround?  I don't want to re-invent the wheel if someone else has already found a way to do this.  I can't just subtract 4 hours, since our user community works out of a number of different time zones.  Any suggestions would be appreciated. 

Thanks,
Audrey

Hello,
You should probably store this date in a SQL field (of SD_REQUEST or AM_ACTION) instead of a workflow's variable. Label your new field with "E_xxxxx_UT"

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.






Users browsing this thread: 1 Guest(s)