• 0 Vote(s) - 0 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Help with Auto-Release
#1
I am trying to configure a auto release for the hold status via a business rule, however I am unable to get the https://xxxxxx.easyvista.com/WebService/SmoBridge.php?wsdl to work in WEB Services. Is anybody able to suggest a workaround, or a alternative way of removing a incident off hold?
Andrew.lowery, proud to be a member of EV CONNECT FORUM since Aug 2018.

#2
(08-02-2018, 03:39 AM)Andrew.lowery Wrote: I am trying to configure a auto release for the hold status via a business rule, however I am unable to get the https://xxxxxx.easyvista.com/WebService/SmoBridge.php?wsdl to work in WEB Services. Is anybody able to suggest a workaround, or a alternative way of removing a incident off hold?

Any idea what error code you're receiving when the Web Service is used? Have you tried the Web Services Test client?
cmiller, proud to be a member of EV CONNECT FORUM since Oct 2015.

#3
(08-02-2018, 08:54 AM)cmiller Wrote:
(08-02-2018, 03:39 AM)Andrew.lowery Wrote: I am trying to configure a auto release for the hold status via a business rule, however I am unable to get the https://xxxxxx.easyvista.com/WebService/SmoBridge.php?wsdl to work in WEB Services. Is anybody able to suggest a workaround, or a alternative way of removing a incident off hold?

Any idea what error code you're receiving when the Web Service is used? Have you tried the Web Services Test client?

As Chris says you can test yours webservice by using the test page : https://xxxxxxxx.easyvista.com/WebServic...Client.php

It's very usefull to test SOAP and webservice (REST or SOAP) are only solution to restart a request.

Please send your error at Easyvista support exceptionally if you're in SaaS plateform.

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.

#4
(08-02-2018, 03:39 AM)Andrew.lowery Wrote: I am trying to configure a auto release for the hold status via a business rule, however I am unable to get the https://xxxxxx.easyvista.com/WebService/SmoBridge.php?wsdl to work in WEB Services. Is anybody able to suggest a workaround, or a alternative way of removing a incident off hold?

Hi Andrew
Were you able to get this working? If so, are you able to provide details of how you did this?
While I understand the concepts around APIs, I'm not familiar with using them.
Thanks
Dean, proud to be a member of EV CONNECT FORUM since Jul 2018.

#5
(09-25-2018, 01:02 PM)Dean Wrote:
(08-02-2018, 03:39 AM)Andrew.lowery Wrote: I am trying to configure a auto release for the hold status via a business rule, however I am unable to get the https://xxxxxx.easyvista.com/WebService/SmoBridge.php?wsdl to work in WEB Services. Is anybody able to suggest a workaround, or a alternative way of removing a incident off hold?

Hi Andrew
Were you able to get this working? If so, are you able to provide details of how you did this?
While I understand the concepts around APIs, I'm not familiar with using them.
Thanks

Hello,
Concept is as follows:
1/ Trigger AM_ACTION for suspend (only with expected recovery date)
Code:
INSERTED.ACTION_TYPE_ID=5 AND INSERTED.EXPECTED_END_DATE_UT is not null


Workflow: Store expected recovery date in SD_REQUEST
Code:
UPDATE SD_REQUEST SET REQUESTED_CHANGE_DATE_END=(select EXPECTED_END_DATE_UT FROM AM_ACTION WHERE ACTION_ID=@@ID@@) where REQUEST_ID=(select REQUEST_ID FROM AM_ACTION WHERE ACTION_ID=@@ID@@)

2/ Create a scheduled alert (every hour) to check if tickets have exceeded the scheduled pick-up date

Code:
SD_REQUEST.REQUEST_ID IN  (select REQUEST_ID from SD_REQUEST where STATUS_ID=5 AND  REQUESTED_CHANGE_DATE_END<getutcdate())

Update SD_REQUEST (I use MARK_1 but it already use by evaluation...)
Code:
update SD_REQUEST SET MARK_1=1 WHERE REQUEST_ID IN (#LIST_ID#)

3/ Trigger update of MARK_1

Workflow:
- Use webservice to restart
- erase MARK_1 and REQUESTED_CHANGE_DATE_END (for future hold)
- Send email if necessary

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.

#6
Thanks Philippe
I had a bit of difficulty following the steps you outlined. I'm new to EV, and not very technical either.
I've set up an alert and business rule that seems to do the job. I've attached the details of how I've done it, it may prove helpful to other EV noobs in the future.
if you, or anyone else sees any issue with the approach I've taken let me know and I'll update the document, or change the way I've set this up in our environment, depending on the feedback.
Thanks

Dean, proud to be a member of EV CONNECT FORUM since Jul 2018.

#7
(10-12-2018, 11:10 AM)Dean Wrote: Thanks Philippe
I had a bit of difficulty following the steps you outlined. I'm new to EV, and not very technical either.
I've set up an alert and business rule that seems to do the job. I've attached the details of how I've done it, it may prove helpful to other EV noobs in the future.
if you, or anyone else sees any issue with the approach I've taken let me know and I'll update the document, or change the way I've set this up in our environment, depending on the feedback.
Thanks

Hello,
First you don't trigger the hold/suspend (only with expected recovery date). You alert 'Take call off Hold' never find a record

Second i prefer use SD_REQUEST instead of AM_ACTION for schedul alert (and then business rule)

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.






Users browsing this thread: 1 Guest(s)