• 0 Vote(s) - 0 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Date field not converted to timezone in questionnaire
#1
Hi,
 
I have created a questionnaire with one question. The only question in this questionnaire is the planned implementation date. In the database this is the field REQUESTED_CHANGE_DATE_START. This field has been filled earlier in the process and the question selects the value of this field to prefill the date in this question (as default setting). See the attachment.     

The date is stored in the the UTC time zone in the database. In ‘normal’ representations date fields can be 'recalculated' to the correct time zone the user is in. This option is not available in the questionnaire.

Is it possible to recalculate this field with some kind of query in the question editor window?

Thanks!
Frank
Frank Magnin, proud to be a member of EV CONNECT FORUM since Feb 2016.

#2
(09-27-2019, 03:31 AM)Frank Magnin Wrote: Hi,
 
I have created a questionnaire with one question. The only question in this questionnaire is the planned implementation date. In the database this is the field REQUESTED_CHANGE_DATE_START. This field has been filled earlier in the process and the question selects the value of this field to prefill the date in this question (as default setting). See the attachment. 

The date is stored in the the UTC time zone in the database. In ‘normal’ representations date fields can be 'recalculated' to the correct time zone the user is in. This option is not available in the questionnaire.

Is it possible to recalculate this field with some kind of query in the question editor window?

Thanks!
Frank

Hello,
You have this problem of time zone on Backoffice or Apps ?

It's possible to use SQL function "dateadd" but i don't recommand

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.

#3
I have the issue in the Backoffice
Frank Magnin, proud to be a member of EV CONNECT FORUM since Feb 2016.

#4
The problem is that if you transform the dates/times for display according to the timezone of the connected person (if possible) you will have to transform them back for storage in utc

(09-27-2019, 10:11 AM)Frank Magnin Wrote: I have the issue in the Backoffice

Hello,
I've same things, it's a reproduced bug (R190614_00004) in SA and SE.

P.ABBE
ABBE Philippe, proud to be a member of EV CONNECT FORUM since Nov 2015.






Users browsing this thread: 1 Guest(s)