• 0 Vote(s) - 0 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Questionnaire not working - max_input_vars -front: php 5.6.40 instead of php 5.4.45.
#1
Hi,
 
We recently updated our ev front php version to 5.6.40 from  5.4.45 (due to fact that rest api was not working and we ned it).
 
Upgrade went well - all features working nicelly, rest api available. 
 
Everything but (alway that but) certain questionnaires.
 
Questionnaires are showing nicelly, you can enter evertything, no errors are visible from the customer perspective - but after questionnaire submitted there is notthing written in database table SD_QUESTION_RESULT, also no errors recorded on application server side.
 
We tshooted and tried all different kind of questionnaire, different clients, browsers even different front server version (apachi on windows server):
-the same questionnaire is working on (php 5.4 apachi on windows server)
-questionnaire is not working from (Chrom, IE 11, Edge) 
-tried from different client windows 7, windows 10, 2k12 r2 
-changed questionnaire in all possible ways - less questions, some questions removed, added
-checked logs on front server
 
In php log we did catch  warnings about parameter vars. 
In php.ini conf file is set to:
 grep max_input_vars /etc/php.ini
max_input_vars = 1000000
 
But same thing is happening.
 
Questionnaire is using around 30 different questions, what we tried it looks that grid type of questions is influencing. I set one grid question with more than 200 possible choices - and that didn't work. 
When I split same questionnaire in 5 sections with average number of choices - it works (as it's writing in db after each section), but that is not solving our problem as we do need to use large questionarries with large number of possible choices. Plus grid questions are dynamic sql questions - and nobody knows when it will crach again.
 
If someone knows how to tweek settings for front (or maybe app server) in order to accept large questionnaires.
 
EV version in case needed:
Servers
Smo Broker Version 2016.1.297.0
Smo Server Version 
2016.1.300.0
Easyvista Server 
2016.1.317.0
Platform 
x86
 
Databases
Data DB Version 2016.1.300.0.171207
Admin DB Version 
2016.1.300.0.171207
Reference DB Version 
2016.1.300.0.171207
Config DB Version 
2016.1.300.0.171207
BackOffice DB Version 
2016.1.300.0.171207
 
PHP
PHP Pages Version 2016.1.300.0
PHP 
5.6.40
doktabar, proud to be a member of EV CONNECT FORUM since Nov 2015.

#2
Issue was solved - the key is definatelly:

max_input_vars

We were checking parameter in wrong folder as on this front server older php version was also installed.

With max_input_vars=10000 everything works fine.
doktabar, proud to be a member of EV CONNECT FORUM since Nov 2015.






Users browsing this thread: 1 Guest(s)