• 0 Vote(s) - 0 Average
  • 5
  • 4
  • 3
  • 2
  • 1
Thread Modes

Integraton model - code page issue
#1
Guys,
 
I'm trying to create schedulled integration with our Oracle DB.
 
It seems to me that I have issue with special signs: ČčĆ掞ŠšĐđ when read by EV integration model. When I replace integration model query to replace characters czsd – it is working, but at this stage it is not acceptable as a solution.
 
EV MSSQL 2k14 DB - has collation Latin1_General_CI_AS
Oracle DB - NLS_CHARACTERSET      EE8ISO8859P2

I would dare to say it'ss LATIN1 and LATIN2 standars.
 
However, when I use integraton query eg.
 
select 'this is working' as name
  form...
 
It works fine.
 
select '蚊đĆ掞Čč' as name
 
No luck.
I've tested each single character but when in query results of integration for them can be three:
-converts character č into c (by itself)
-Missing CommandText property - and integration is not completed - for Č,Ć,đ,Š
-display ?? as sign and it pass - for Žžš
-works as it should - for Đ
 
I've tried replacing with chr() equivalent od MSSQL collation for each sign:
 
replace(replace(replace(replace(replace(replace(replace(replace(replace(replace('text to replace','č',chr(232)),'ć',chr(230)),'š',chr(154)),'ž',chr(158)),'Č',chr(200)),'Ć',chr(198)),'Š',chr(138)),'Ž',chr(142)),'Đ',chr(208)),'đ',chr(240))

But again same errors and not working.

Also tried with:

ALTER SESSION SET NLS_CHARACTERSET = ' AL32UTF8 ';
and query after it - but EV can't do that job as part of integration model.

And thoughts, ideas, workarounds - solutions (maybe) would be more than welcome.
doktabar, proud to be a member of EV CONNECT FORUM since Nov 2015.






Users browsing this thread: 1 Guest(s)